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1 Introduction 

 

This document describes the setting up and operational use of the Invoicer software. 

 

1.1 License Agreement 

 

The Invoicer software is licensed to the end user to be installed on one computer per 

individual license. This software requires registration whereby the installed computer 

ID is required. 

 

1.2 Publishing Rights 

 

Axion Control Systems Pty Ltd reserves the right to make periodic changes, revisions, 

specification enhancements and alterations of any kind to the product and this manual 

without obligation to notify any person(s), institution or organisation of such changes, 

revisions, enhancements and alterations. 

 

1.3 Publishing Details 

 

Axion Control Systems authors have taken due care in the preparation of this 

document and every attempt has been made to ensure its accuracy and completeness. 

In no event will Axion Control Systems be liable for damages of any kind, incidental 

or consequential, in regards to or arising out of the performance or form of the 

material presented in this document. 

 

Axion Control Systems encourages feedback about this document. Please send any 

written comments to the Technical Support Department. 

 

 

© Trademarks 
 

Windows 7, 2000, NT, XP and Vista are trademarks or registered trademarks of 

Microsoft Corporation. Microsoft ® are trademarks or registered trademarks of 

Microsoft Corp. Axion are trademarks or registered trademarks of Axion Control 

Systems, all other trademarks or registered trademarks are the property of their 

respective owners. 

 

No part of this publication may be reproduced, copied, transmitted, transcribed, 

plagiarised, or translated into any language in any form by any means without the 

written permission of Axion Control Systems Pty. Ltd. 
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1.4 Definitions 

 

AXIBATCH  Concrete Batching and Docketing Software. 

 

CONSOLE  Program that allows editing of the AxiBatch Database 

and run reports  

 

AXIBATCH DATABASE  Main Database including Recipe and Customer tables, 

and the Completed Loads Database containing 

completed batch records 

 

AGGREGATES  Materials such as stone and sand that are used to make 

Concrete and that are loaded into large Hoppers via a 

Front End Loader or an Overhead Bin Plant.\ 

 

INVOICER  A separate software that produces invoices from 

completed loads that reside in the Completed Loads 

database. 

 

PREORDER  An order that resides in the PREORDER table in the 

database and appears in a Grid View on the Top Left of 

the main screen of AxiBatch. You cannot batch from 

these records. 

 

PROGRESSIVE  An order that has been transferred from the 

PREORDER table to the BATCH table. It resides in the 

BATCH table in the database and appears in a Grid 

View on the Bottom Left of the main screen of 

AxiBatch. You can batch from these records. 

 

PLC  Programmable Logic Controller. An industrial stand 

alone computer that controls and monitors the plant 

input and outputs. 

 

AXISOFT  A PLC emulator that runs on a computer that 

communicates to Ethernet devices for Input Output 

control. This allows for partial to full automation. 
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1.5 Features 

 

Invoicer is designed to run on a Microsoft Windows operating system. 
Invoicer software package was written using Microsoft C# and requires Net 
Framework 4 to run. This software should run on most Microsoft operating 
systems that use Net Framework 4, which includes XP Service Pack3 and 
Windows 7/10. The software was designed to meet the growing needs and 
requirements for weight and data capture in industry today. 
 
Invoice can accommodate multiple Invoice Databases if required, however 
the Invoice Layout and Export function is all common. 
 

1.6 PreRequisites 

 

Invoicer will only work with AxiBatch data. 
 
Invoicer requires the 32-bit Firebird Database Engine Version 2.5.3 to 
V2.5.9 to be installed on the same computer that Invoicer is installed. 
 
Invoicer requires the 32-bit Crystal Reports for Visual Studio 2010 Reports 
runtime Engine Version 13.0.1.220 to be installed on the same computer 
that Invoicer is installed. 
 
Minimum V4 of Microsoft Net Framework must be installed, if it is not. 
 
Console should be installed alongside Invoicer, to give you access to 
Customer Table.  
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2 Getting Started 

 

2.1 Launching Invoicer 

 

Double Clicking the Invoicer icon on the desktop will launch the Invoicing 

software. The main Invoicer screen below will be displayed. 

 

 
 

2.2 Logging In 

Use the  icon to invoke the login screen. 
 
Invoicer software identifies three user levels and their passwords for 
authentication and protection. 
 
 

Level 1 Operator user name only gains access to operating the 
plant and viewing Reports. 

 
 
 
Level 2  Administrator user name has access to the same 

functions as the operator plus access to most of the 
settings. 

 
 
Level 3  Technician user name gains full access.  
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The Invoicer software will 
automatically come with 3 
user names. They are 
Operator, Administrator and 
Technician. 
 
You will need the 
Administration / Technician 
level to be able to configure 
most functions. 
 
 

 

2.3 Adding or Editing Users 

 
Firstly, log in as an administrator. 
 
Select Master Database->Users to display the Users screen. 
 

 
 

22..33..11  AAddddiinngg  aa  UUsseerr  

 
Click in the spare operator cell down near the bottom of the grid and type the 
name of the operator and press Enter.  
 
Right click with the mouse and select “Change User Level”. Select the level as 
1 or 2. Press the “Change” button. 
 
Right click on the line and select change password. Enter the new password 
and repeat it in the last line and select “Change”. 
 

Press the Save button to save the changes.  

Password Required 
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22..33..22  EEddiittiinngg  aa  UUsseerr  

 
Select the user in the grid. 
 
Right click with the mouse and select “Change User Level”. Select the level as 
1 or 2. Press the “Change” button. 
 
Right click on the line and select change password. Enter the new password 
and repeat it in the last line and select “Change”. 
 

Press the Save button to save the changes.  
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3 Database Setup 
 

There will be some configuration before Invoicer can be used properly. 

 

In summary, you will always have a Master Invoice Database. This is called 

“MASTER.FDB” and will usually by default stored in “C:\AxiBatch 

Data\Invoices\Databases” directory. However, is typically stored on a Server 

computer so it can be accessed by everyone using Invoicer. The Master database will 

store data on the Users, User Allocation, Plants, Invoice Databases, Accounts. 

 

The Users table will store all the Users that use Invoicer. 

The Users Allocation table will store which users have access to which Invoice 

databases. 

The Plants table stores information for each plant and where the AxiBatch database 

for that plant is located. It also stores the Prefix for the Invoice and which Invoice 

Database its invoices will be allocated to.  

The Accounts table stores all the recipe and miscellaneous items along with the 

Account Code or Number and or Name that is used for that item in the accounting 

software. 

The Invoice Database Allocation table stores the Invoice database Name, where it is 

located. It can also have a prefix name and will store the tracking of invoice numbers 

in reference to the generation, printing and exporting. 

 

The Invoice Database can be just one database or can be multiple databases.  

 

This is set up in Settings. If in “Settings->Database->Enable Multiple Invoice 

Databases” is checked then Invoicer will use the Invoice Databases in the “Invoice 

Database Allocation Table”, otherwise will use the one “INVOICER.FDB” database 

that resides in the same directory as the Master Invoice Database. 

 

The location of the Master Database and singular Invoicer Database are set by 

“Settings->Database->Master Invoice Database Path” in settings. 

 

3.1 Setting up Multiple Invoice Databases 

 

These databases are created automatically when you restart Invoicer, after configuring 

in the Invoice Database Allocation table. 

 

The fields in the table are as follows … 

 

 Invoice Database Name – This is the full name of the Invoice database (no 

need for the extension here) (Max 40 Characters) 

 Description – Description of that the database is used for (Max 100 

Characters) 

 Enabled or Disabled – Whether the Database is “Enabled” or “Disabled” for 

use. 
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 IP Address or Computer Name – This is the location of the external computer 

where the database is stored. Preferably use an IP Address. If the database is 

on the local machine leave this field blank. 

 Pathname – Directory location of where the database is stored 

 Source Pathname for Backup – This is location of the database using a mapped 

drive path. This is used so the database can be backed up. 

 Invoice PreFix – The prefix that is used for this Invoice 

 Export Type Used – This is for future (currently you can only have one export 

type) 

 Export Inv No Start – This stores the Invoice Number start number for Export. 

It is automatically updated, however can be overwritten if there were issues. 

 Export Inv No End – This stores the Invoice Number end number for Export. 

It is automatically updated, however can be overwritten if there were issues. 

 Print Inv No Start – This stores the Invoice Number start number for Printing 

and Emailing. It is automatically updated, however can be overwritten if there 

were issues. 

 Print Inv No End – This stores the Invoice Number end number for Printing 

and Emailing. It is automatically updated, however can be overwritten if there 

were issues. 

 

 

3.2 Invoice Grid Buttons 

 
The navigator at the top of the page consists of the following objects. 
 

  
First Record - Pressing this takes you to the first record. 
 

   
Previous Record - Pressing this takes you to the previous record. 
 

  
Record Number - This displays the current record number. Typing a number 
and then pressing enter will take you to the record number that you have 
entered. 
 

  
Next Record - Pressing this will display the next record. 
 

  
Last Record - Pressing this will display the last record. 
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Add Record - Pressing this will add a row to the bottom of the table. (You can 
also add a row manually by just typing in the last empty row that has a cursor 
on the left hand side of the screen). 
 

  
Delete Record - This will delete the record selected. (Selected record has an 
arrow head located on the left hand side of the screen.) 
 

  
Save - This will light up when editing has occurred. Otherwise will be greyed 
out. Pressing this will commit all changes to the database. 
 

  
Cancel - Will undo any changes on the current record you are in. 
 

  
Rollback - Will undo all edits before the last Save was done. It will prompt 
you with a Yes or No prompt. 
 

  
Search For - The search text 
 

  
Search In - The Field column you want to do the search in. You must select 
the field first, then type in the text in the Search For area. it will search part 
words. If a full match is found the whole row will be highlighted in blue. 
 

  
Order By - Will refresh the database with the order you selected. If you want 
to reorder without refreshing the database, click on the column headers. This 
is much faster. 
 

 
Refresh Product Table - Will refresh the data from the Database. 
 

 
Print - Will print a report that have select from the "Select a Report" combo 
box. 
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Notes 
 

1. In some cases, some of the buttons are not enabled. Editing a record may be as 

simple as right clicking on the record and selecting an option from the context 

menu. Usually this method offers a more advanced and simplified form of 

editing or inserting a record. 

 

2. Sometimes no or little information may appear in the grid table, this is because 

of the initial filter used to grab data from the database. This is to speed up the 

update time of the screen. Use the "Show Filters" button to make a popup 

appear that will filter and update data. Filters options change from table to 

table. Filters can include objects like date ranges, customer code etc. 

 

3. Most tables are edited using the Console software. This software is provided 

with AxiBatch or Invoicer. Tables that are edited only in AxiBatch relate to 

the specific plant and include the Bin Setup Table, Discharge Table, Water 

Adjust Table. Also included are the editing of the Order and Progressive 

Order. 
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3.3 Allocating Users to Invoice Databases 

 

Once the multiple Invoice databases have been allocated, you can allocate users to 

each database. You can allocate multiple users to the one database. 

 

To access this, select “Master Database->Allocate Inv database to Users”. 

 

 
 

To add a user, select a user from the User Name drop box, and then select Invoice 

Database from the Invoice Database Name drop box. Press the “Insert” button to add 

that allocation.  

 

When you log in to an Invoice Database, only the users that are allocated to this 

database will appear in the Login list. 
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3.4 Backing up Databases 

 

Once the Databases have been set up, you will need to setup how they are backed up. 

 

Go to “Settings->Backup” and start setting up where the database as settings will be 

backed up. 

 

 
 

Checking “Auto Backup before Exit”, enables the backing up process. 

 

Prompt Me, checked will ask the operator whether to perform the backup or not. 

 

Add Time Date Stamp, should be checked, to avoid replacing a corrupted database. 

This will add a date and time to the end of the database filename. 

 

Keep up to is the number of days you wish to keep in the backup directory. Anything 

older than this will be deleted to keep the memory available in reasonable order. 

 

There are two separate locations you can back up to. Make sure at least one location is 

external to the computer! 

 

When you exit Invoicer (still logged in), is when the backup will occur. 
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4 Setting Up how Invoices will be Generated 

 

This section describes how to setup how invoices are generated. 

 

4.1 Enable Generation 

 

To enable Invoicer to be able to generate, check “Settings->Invoices->Enable Invoice 

Generation” 

 

If you don’t do this, you will not be able to generate invoices. 

 

 

4.2 Generation Mode 

 

Select how Invoicer will generate Invoices. 

 

44..22..11  CCuussttoommeerr  CCooddee  

 

Invoices will be generated based only on the Customer Code. If you have one weeks’ 

worth of dockets, all the dockets for that Customer Code will appear on that one 

invoice. 

 

You can select the order of how they appear in that invoice. It can be by Delivery 

Date, Delivery Date as Descending, Delivery Address or Docket. 

 

44..22..22  CCuussttoommeerr  CCooddee//DDeelliivveerryy  AAddddrreessss  

 

Invoices will be generated based only on the Customer Code and the Delivery 

Address. If you have one weeks’ worth of dockets, all the dockets for that Customer 

Code and the Same Delivery address will appear on one invoice. So, if that customer 

had 2 delivery addresses, then 2 invoices will have been generated for that customer. 

 

The Order box has no relevance. The order of the Invoice will be by Date and Time 

and then by Docket Number. 

 

 

44..22..33  CCuussttoommeerr  CCooddee//DDeelliivveerryy  DDaattee  

 

Invoices will be generated based only on the Customer Code and the Delivery Date. If 

you have one weeks’ worth of dockets, all the dockets for that Customer Code will 

have 1 invoice per day with multiple Delivery addresses on one invoice.  
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The Order box has no relevance. The order of the Invoice will be by Date and Time 

and then by Docket Number. 

 

 

44..22..44  CCuussttoommeerr  CCooddee//DDeelliivveerryy  DDaattee//DDeelliivveerryy  AAddddrreessss  

 

Invoices will be generated based only on the Customer Code, Delivery Date and the 

Delivery Address. Hence there will be an invoice per day and per delivery address. 

 

The Order box has no relevance.  

 

 

44..22..55  CCuussttoommeerr  NNaammee  

 

Invoices will be generated based only on the Customer Name. If you have one weeks’ 

worth of dockets, all the dockets for that Customer Name will appear on that one 

invoice. 

 

You can select the order of how they appear in that invoice. It can be by Delivery 

Date, Delivery Date as Descending, Delivery Address or Docket. 

 

 

44..22..66  CCuussttoommeerr  NNaammee//DDeelliivveerryy  AAddddrreessss  

 

Invoices will be generated based only on the Customer Code and the Delivery 

Address. If you have one weeks’ worth of dockets, all the dockets for that Customer 

Code and the Same Delivery address will appear on one invoice. So, if that customer 

had 2 delivery addresses, then 2 invoices will have been generated for that customer. 

 

The Order box has no relevance. The order of the Invoice will be by Delivery Address 

and then by Date and Time. 

 

 

44..22..77  CCuussttoommeerr  NNaammee//DDeelliivveerryy  DDaattee  

 

Invoices will be generated based only on the Customer Name and the Delivery Date. 

If you have one weeks’ worth of dockets, all the dockets for that Customer Name will 

have 1 invoice per day with multiple Delivery addresses on one invoice.  

 

The Order box has no relevance. The order of the Invoice will be by Date and Time 

and then by Docket Number. 
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44..22..88  CCuussttoommeerr  NNaammee//DDeelliivveerryy  DDaattee//DDeelliivveerryy  AAddddrreessss  

 

Invoices will be generated based only on the Customer Name, Delivery Date and the 

Delivery Address. Hence there will be an invoice per day and per delivery address. 

 

The Order box has no relevance.  

 

 

44..22..99  UUssee  DDoocckkeett  NNuummbbeerr  ffoorr  IInnvvooiiccee  NNuummbbeerr  

 

If you check this the Generation Type is irrelevant. 

 

Basically, here each docket is turned into an invoice and the invoice number used is 

the actual docket number. 

 

 

4.3 Actions When Generating 

 

44..33..11  DDoocckkeett  CChheecckk  

 

When generating you can perform a check that the docket number is not already 

invoiced, and then perform an automatic action if it is. 

 

The enable this function check “Settings->Invoices->Generation->Perform Check on 

Docket Number”. 

 

To select an action, select from the action selection box below the above setting. 

 

Add to Invoice – Will add to Invoice regardless 

Do Not Add to Invoice (default) – Will not add to invoice 

Prompt to add to Invoice – Will prompt operator. 

 

Note: More checks are being added at an earlier stage so best option here is the “Will 

not add to Invoice”. 

 

 

44..33..22  MMIISSCC  QQttyy  

 

Checking “Settings->Invoices->Generation->Calculate MISC Qty as Qty * Load for a 

rate Type” will perform the following on Miscellaneous types that are of type Rate, 

which is based on CuM of concrete. 
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E.g. If you bag of oxide and it is set up as a Rate type and you have 10 kg per CuM of 

concrete. If the operator doubles it the quantity field will contain 2. If you have a 

5CuM load, then you will have 20kg per CuM, with a total of 100kg. Then checking 

the above will make the quantity as 10, instead of 2. 

 

 

44..33..33  AAccccoouunntt  CCooddee  CChheecckk  

 

Whilst you are generating you can check if Account Codes exist for the Recipe or 

Miscellaneous item. 

 

To enable this check “Settings->Invoices->Generation->Perform Check on Account 

Code”. 

 

When generating and the above is enabled and no account code is found for the 

Recipe, then a form will appear that will ask you to enter it on the spot. 

 

Type in the Account Code / Number or Name, add the description, select the Plant 

and enabled it. Press “Add to Account Table” to add this Account Code to the 

Accounts table. 

 

You can press “Skip” if you wish to add this manually to the accounts table later. 

 

The Account codes are used when exporting to your accounting package. 

 

 

44..33..44  DDuuee  DDaattee  OOffffsseett  

 

This is the default Due date offset. You can overwrite this and set the exact due date 

before you start to generate on the generate form. 

 

To set the offset days type in the days in “Settings->Invoices->Generation->Due Date 

Offset”. 

 

 

44..33..55  DDeeffaauulltt  PPaatthh  ffoorr  GGeenneerraattiioonn  RReessuullttss  

 

This is the default path to save the generation results after Invoicer has performed a 

generation. 

 

To set the path type the path in “Settings->Invoices->Generation->Default Path for 

Generation Results”. 
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44..33..66  SSeeppaarraattee  tthhee  CCaarrttaaggee  FFeeee  ffrroomm  tthhee  CCoonnccrreettee  CCoosstt  ttoo  aa  SSeeppaarraattee  

LLiinnee  

 

To separate the Cartage fee to a separate line in the Invoice for a Big Truck check 

“Settings->Invoices->Generation->Gen Field Options->Separate Cartage Fee from 

Concrete Cost for Big Trucks”. 

 

To separate the Cartage fee to a separate line in the Invoice for a Mini Truck check 

“Settings->Invoices->Generation->Gen Field Options->Separate Cartage Fee from 

Concrete Cost for Mini Trucks”. 

 

 

44..33..77  SSeeppaarraattee  tthhee  FFllaatt  CChhaarrggee  oorr  DDiissccoouunntt  ffrroomm  tthhee  CCoonnccrreettee  CCoosstt  ttoo  aa  

SSeeppaarraattee  LLiinnee  

 

To separate the Flat Fee or Discount from the Concrete Cost to a separate line in the 

Invoice check “Settings->Invoices->Generation->Gen Field Options->Separate Flat 

Charge / Discount from Concrete Cost”. 

 

 

44..33..88  AAdddd  DDeelliivveerryy  AAddddrreessss  ttoo  tthhee  DDeessccrriippttiioonn  LLiinnee  ooff  tthhee  IInnvvooiiccee  

 

You can add the Delivery address to the Description field in the invoice. This is 

normally used when you have multiple delivery addresses on the one invoice. 

 

To add the Delivery Address (Line 1) from AxiBatch to the description field check 

“Settings->Invoices->Generation->Gen Field Options->Add Delivery Address Line 1 

to Description Field”. 

 

To add the Delivery Address (Line 2) from AxiBatch to the description field check 

“Settings->Invoices->Generation->Gen Field Options->Add Delivery Address Line 2 

to Description Field”. 

 

If you want to merge the Delivery Address Line 1 with Line 2 on the same line then 

check “Settings->Invoices->Generation->Gen Field Options->Merge with 1st 

Address”. 

 

If you do not want to duplicate the same delivery address in the same invoice then 

check “Settings->Invoices->Generation->Gen Field Options->Do Not Duplicate on 

same Invoice”. 

 

If you want to add the Delivery Address to all records then check “Settings->Invoices-

>Generation->Gen Field Options->Add Delivery Address to all Records in the Detail 
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Table”. If this is not checked then the delivery address will only appear after the 

Recipe Mix. 

 

 

44..33..99  AAdddd  tthhee  OOrrddeerr  NNuummbbeerr  ttoo  tthhee  IInnvvooiiccee  DDeettaaiill  DDeessccrriippttiioonn  

 

You can add the Order Number to the Description field in the invoice. This is 

normally used if you do not show Order Number anywhere else on the Invoice, I.e. as 

a column or in the header. 

 

To add the Order Number from the AxiBatch docket to the description field check 

“Settings->Invoices->Generation->Gen Field Options->Add Order Number Field to 

Invoice Detail Description”. 

 

 

44..33..1100  AAdddd  tthhee  CCoommmmeenntt  ttoo  tthhee  IInnvvooiiccee  DDeettaaiill  DDeessccrriippttiioonn  

 

You can add the Comment from the AxiBatch docket to the Description field in the 

invoice.  

 

To add the Comment from the AxiBatch docket to the description field check 

“Settings->Invoices->Generation->Gen Field Options->Add Comment Field to 

Invoice Detail Description”. 

 

 

44..33..1111  AAdddd  tthhee  DDoocckkeett  NNuummbbeerr  ttoo  tthhee  IInnvvooiiccee  DDeettaaiill  DDeessccrriippttiioonn  

 

You can add the Docket Number to the Description field in the invoice, if you do not 

have a Docket Column on your Invoice.  

 

To add the Docket Number from the AxiBatch docket to the description field check 

“Settings->Invoices->Generation->Gen Field Options->Add Docket Number to 

Invoice Detail Description”. 

 

 

44..33..1122  CChhaannggee  tthhee  CCrreeddiitt  CCaarrdd  DDeessccrriippttiioonn  

 

When you generate you can change the default Credit Card description to whatever 

you like. The default is “Credit Card Charge”. 
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44..33..1133  CChhaannggee  tthhee  DDeessccrriippttiioonn  ooff  tthhee  SShhoorrtt  LLooaadd  

 

You can change the description of the Short Load default “ShortFall” in “Settings-

>Invoices->Generation->ShortLoad->ShortFall Name”. 

 

44..33..1144  IInncclluuddee  tthhee  SShhoorrtt  LLooaadd  FFeeee  aass  ppaarrtt  ooff  tthhee  CCoonnccrreettee  CCoosstt  

 

If you want the Short Load costs included as part of the Concrete cost then check 

“Settings->Invoices->Generation->ShortLoad->Include ShortFall Fee as part of the 

Concrete Cost “. 
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5 Creating your Invoice Layout 

 

You can bypass this section if you are going to be printing invoices from your 

accounting package. 

 

There four sections of the Invoice. 

 

 Header, this appears at the top and only on the first page. 

 Detail, this is the details of the Invoice, it will show multiple columns and you 

can use all the header objects to appear in the top of the Detail body on each 

page by supressing the Header 

 Summary, this is a summary of the totals for the page and will always appear 

on the last page 

 Footer, this is a footer page that always appears on the bottom of every page 

 

Keep in mind that the positions and heights and widths are all in pixel. 

 

For an A4 page the width is around 11400 pixels. The Height is always based from 

the top of the actual section. So, if you say a top position is 1000, and it is in the 

Footer Section, this is 1000 pixels from the top of the Footer section. 

 

5.1 Boxes and Lines 

 

In various areas you will see options to configure boxes and lines. This describes the 

fields for these items and applies to all. 

 

There will always be a check box to enable the line or box, check this to make it 

appear. 

 

 Left, this is the left position of the box or line 

 Right, this is the right position of the box 

 Top, this is the top position of the Box or line 

 Bottom, this is the bottom position of the Box 

 Drop Shadow, check this create a shadow for Box or Line depending on the 

line thickness 

 Extend to Bottom of (Section), will extend the Box to the bottom of the 

Section 

 Line Color, select the color of the Line or Box (double left click to invoke the 

color dialog) 

 Fill Color, select the color to fill the Box (double left click to invoke the color 

dialog) 

 Ellipsis, make the box elliptical shape 

 Line Thickness, this is the thickness of the Line or the Line in the box 

 Line Style, this is the Style of the line in the Line or Box. Options are Single 

Line, Double Line, Dot or Dash 
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Some sections have more boxes available than other sections. Make sure the height of 

the boxes doesn’t extend past the height of the section, otherwise errors will result 

when previewing or printing invoices. 

 

 

5.2 Header 

 

This is top section of the Invoice. This will only appear once and on the first page. 

 

If you want the Header to appear on every page then you will need to check “Settings-

>Invoice Layout->Header->Supress Header and use Detail Header. This will not use 

the standard header and will expand the detail section so some of the Header fields 

will appear at the top of the Detail Section. 

 

If you want to use this Header,  

 

then you can set the height of the Header by typing the height in “Settings->Invoice 

Layout->Header->Section Height”. 

 

then you can set the background color of the Header by selecting the color in 

“Settings->Invoice Layout->Header->Section Color”. Double click with left mouse 

button to select a color from the color dialog box. 

 

The following settings apply to the Header or the Top Section of the Detail Section if 

the Header is supressed. 

 

55..22..11  SShhooww  tthhee  CCoommppaannyy  AAddddrreessss  oonn  tthhee  IInnvvooiiccee  HHeeaaddeerr  

 

Type the Company Address you want to appear in the Header in the “Settings-

>Invoice Layout->Header->Company Address Details Text” text box. 

 

Set the left position of the text by typing in the position value in “Settings->Invoice 

Layout->Header->Left Position” below the Company Address text box. 

Set the top position of the text by typing in the position value in “Settings->Invoice 

Layout->Header->Top Position” below the Company Address text box. 

 

Set the color of the text selecting the color in “Settings->Invoice Layout->Header-

>Forecolor” below the Company Address text box. Double click with the left mouse 

button to invoke the color dialog box. 

 

Set the justification of the text by selecting the justification in “Settings->Invoice 

Layout->Header->Justification” below the Company Address text box. 

 

Set the Font of the text by selecting the font in “Settings->Invoice Layout->Header-

>Font” button. This will show the font dialog box. 
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55..22..22  SShhooww  tthhee  CCoommppaannyy  LLooggoo  

 

Type in the location pathname and filename of the logo file in the text box in 

“Settings->Invoice Layout->Header->Company Logo / Watermark”. 

 

Enable it by checking the “Show Logo” box. 

 

You can show the Logo as a watermark by checking “Show as Watermark”. This will 

make the logo appear on every page. 

 

Set the Logo Left and Top positions. 

 

You can adjust the Height and Width of the logo by placing the value in the Logo 

Height and Logo Width boxes. 

 

 

55..22..33  HHeeaaddeerr  SSttaattiicc  UUsseerr  TTeexxttss  

 

You can have up to 9 different static text fields in the Header section. 

 

These are located in “Settings->Invoice Layout->Header->Header Texts” and 

“Settings->Invoice Layout->Header->Header Texts->Header Texts2” and “Settings-

>Invoice Layout->Header->Header Texts->Header Texts3”. 

 

Texts are simply typed in the Text Box. 

 

To enable the text to appear on the Invoice check the “Enable” box. 

 

To set the Left Position of the text type the left position in the “Left Position” box. 

To set the Top Position of the text type the top position in the “Top Position” box. 

To set the Width of the Text Field type the width in the “Width” box. (Make sure the 

text you type appears fully otherwise you may have to increase the width). 

To set the font of the text press the Font button to select the Font. 

To set the color of the text select the color by double left clicking on the color box, 

this will invoke the color dialog box. 

To set the justification of the text, select from the justification drop down box. 

 

 

55..22..44  DDiissppllaayy  tthhee  IInnvvooiiccee  NNuummbbeerr  

 

This will display the Invoice Number and its associated static text that you set in the 

Header section. 
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This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Invoice Number”. 

 

Enable the Invoice Number and the static Text for the Invoice Number to appear on 

the invoice. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic invoice number field. 

 

 

55..22..55  DDiissppllaayy  tthhee  OOrrddeerr  NNuummbbeerr  

 

This will display the Order Number and its associated static text that you set in the 

Header section. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes->Order 

Number”. 

 

Enable the Order Number and the static Text for the Order Number to appear on the 

invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic order number field. 

 

 

55..22..66  DDiissppllaayy  tthhee  DDuuee  DDaattee  

 

This will display the Due Date and its associated static text that you set in the Header 

section. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes->Due 

Date”. 

 

Enable the Due Date and the static Text for the Due Date to appear on the invoice 

header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic due date field. 

 

 



Invoicer Software Operator's Manual                  22/06/2018 

 

Page - 28 

 

55..22..77  DDiissppllaayy  tthhee  CCuussttoommeerr  CCooddee  

 

This will display the Customer Code and its associated static text that you set in the 

Header section. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 2->Customer Code”. 

 

Enable the Customer Code and the static Text for the Customer Code to appear on the 

invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic customer code field. 

 

55..22..88  DDiissppllaayy  tthhee  IInnvvooiiccee  DDaattee  

 

This will display the Customer Code and its associated static text that you set in the 

Header section. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 2->Customer Code”. 

 

Enable the Customer Code and the static Text for the Customer Code to appear on the 

invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic customer code field. 

 

55..22..99  DDiissppllaayy  tthhee  PPaaggee  NNuummbbeerr  

 

This will display the Page Number and its associated static text that you set in the 

Header section. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 2->Page Number”. 

 

Enable the Page Number and the static Text for the Page Number Code to appear in 

the invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic page number field. 

 

You can also view the Page Number as Page N of M by checking “Use Page N of M”. 

Where N is the page number and M is the total number of pages. 
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55..22..1100  DDiissppllaayy  tthhee  DDeelliivveerryy  DDaattee  

 

Use this if you do not have a Delivery Date column in your detail section and invoices 

are generated by part per Delivery Date. 

 

This will display the Delivery Date and its associated static text that you set in the 

Header section.  

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 3->Delivery Date”. 

 

Enable the Delivery Date and the static Text for the Delivery Date to appear in the 

invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic delivery date field. 

 

 

55..22..1111  DDiissppllaayy  tthhee  DDeelliivveerryy  AAddddrreessss  

 

Use this if your invoices are being generated by part per Delivery Address. (I.e. all 

delivery addresses on the Invoice are the same), and delivery addresses are not 

appearing as part of the description field. 

 

This will display the Delivery Address and its associated static text that you set in the 

Header section.  

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 3->Delivery Address”. 

 

Enable the Delivery Address and the static Text for the Delivery Address to appear in 

the invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic delivery date field. 

 



Invoicer Software Operator's Manual                  22/06/2018 

 

Page - 30 

 

55..22..1122  DDiissppllaayy  tthhee  TToottaall  CCoonnccrreettee  QQuuaannttiittyy  iinn  CCuuMM  

 

This will display the total CuM in concrete used in the Invoice and will display its 

associated static text that you set in the Header section.  

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 3->Total Concrete quantity in CuM”. 

 

Enable the Total Quantity and the static Text for the Total Quantity to appear in the 

invoice header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic delivery date field. 

 

 

55..22..1133  DDiissppllaayy  tthhee  PPAAIIDD  tteexxtt  

 

This will display “PAID” or whatever you type in the “User Text if Paid” text box.  

 

This will display nothing or whatever you type in the “User Text if NOT Paid” text 

box. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Special Codes 4->Paid Field. 

 

Enable the Paid checkbox and the static Text(s) for the Paid to appear in the invoice 

header. 

 

You can set the description text and the positions. Font and color for the static text 

field and the dynamic Paid field. 

 

Paid is set manually once invoices are already generated. 

 

 

55..22..1144  DDiissppllaayy  tthhee  ““IInnvvooiiccee  TToo””  tteexxtt  

 

This is actually the postal address of the where the invoice will be delivered to. 

 

This is located in “Settings->Invoice Layout->Header->Header Special Codes-

>Invoice To Text. 

 

Enable the “Show Customer Name” to display the Customer Name addressed to. Set 

the left, top positions of the text and then set the font and color. 
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Enable the “Show Customer Invoice Address” to display the postal address of where 

the invoice will be sent to. Set the left, top positions of the text and then set the font 

and color. 

 

Enable the “Invoice To Text” to display the user static text. Set the left, top positions 

of the text and then set the font and color. This can be “Invoice To :” as default or set 

to whatever you like. 

 

Enable Box 3 to have a box wrap around all the above text. 

Set in pixels the Left, Right, Top and Bottom positions of the Box. 

Select “Drop Shadow” to have a small shadow effect around the box. 

Select “Extend to Bottom of Header” to have the bottom line of the box appear at the 

bottom of the header. 

Double Left click on Line Color to change the color of the box line. 

Change the Line thickness in pixels in “Line Thickness”. 

Check “Ellipsis” to curve the box to look elliptical. 

Change the Line Style of the box, by selecting the style. (Default Single Line). 

 

 

55..22..1155  DDiissppllaayy  BBooxxeess  

 

You have the option to display 2 other boxes in the Header. 

 

These settings are found in “Settings->Invoice Layout->Header->Header Box 1”. 

 

Enable Box 1 or 2 to have a box wrap around any text. 

Set in pixels the Left, Right, Top and Bottom positions of the Box. 

Select “Drop Shadow” to have a small shadow effect around the box. 

Select “Extend to Bottom of Header” to have the bottom line of the box appear at the 

bottom of the header. 

Double Left click on Line Color to change the color of the box line. 

Change the Line thickness in pixels in “Line Thickness”. 

Check “Ellipsis” to curve the box to look elliptical. 

Change the Line Style of the box, by selecting the style. (Default Single Line). 
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5.3 Details Body 

 

This section describes how to set up the details section of the invoice. The details 

section can have multiple columns, set up in “Settings->Invoice Layout->Detail-

>Detail Fields”. The details, however many lines it always has one header line, that 

have titles for each column. Do not confuse these items with the items that come from 

the Header section. 

 

55..33..11  FFoorrmmaattttiinngg  tthhee  DDeettaaiillss  HHeeaaddeerr  LLiinnee  

 

If you are supressing the main header and want a header to appear on every page then 

you can set the total height of the header section in “Settings->Invoice Layout-

>Detail->Detail Header Row Height”. All items that you set in the Header section will 

appear above the Detail Header titles, so allow enough room in the Height. (I.e. 3000 

to 8000). 

 

Now the Header titles position of the actual Details section can be set at the top 

position in “Settings->Invoice Layout->Detail->Detail Header Top Position”. This 

value needs to greater than the bottom last Header item, if the main Header is being 

supressed. 

 

The back color to this Header Section of the details is set in “Settings->Invoice 

Layout->Detail->Detail Header Section Back Color”. 

 

The headers for the Details of the Invoice font can be set by pressing the “Settings-

>Invoice Layout->Detail->Detail Header Text Font”. The text color can be set by 

double left mouse click of “Settings->Invoice Layout->Detail->Detail Header Color”. 

 

 

55..33..22  FFoorrmmaattttiinngg  tthhee  DDeettaaiillss  ((rroowwss  ooff  IInnvvooiiccee  lliinneess))  

 

The Details height of each line or row can be set by “Settings->Invoice Layout-

>Detail->Row Height (in the Detail Format section). Typical values are around 350. 

The smaller you make this the more rows you will be able to fit, but make sure the 

font is small enough. The Font is set in “Settings->Invoice Layout->Detail->Detail 

Font (in the Detail Format section). 

 

To set the position of the text inside the row height, set “Settings->Invoice Layout-

>Detail->Top Detail Position. (in the Detail Format section). This will enable you to 

center it within the row taking into account the font. 

 

To Change the Detail text color double mouse left click on “Settings->Invoice 

Layout->Detail->Detail Text Color. (in the Detail Format section). 
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If you wish to supress any blank rows that are generated by Invoicer, then check 

“Settings->Invoice Layout->Detail->Suppress Blank Rows”. (in the Detail Format 

section). 

 

To Change the Detail text background color double mouse left click on “Settings-

>Invoice Layout->Detail->Detail Section Back Color”. (in the Detail Format section). 

 

If you want the dollar value fields to be right justified check “Settings->Invoice 

Layout->Detail->Dollar values to be Right Justified. (in the Detail Format section). 

 

55..33..33  SSeett  tthhee  CCoolluummnnss  iinn  tthhee  IInnvvooiiccee  DDeettaaiillss  

 

Go to the “Settings->Invoice Layout->Detail->Detail Fields”. 

 

The column names are on the far left and can be changed. These are the actual headers 

that will appear in the details section. If you hover your mouse over the field a hint 

will appear to remind you what the column is for. 

 

The “Left Pos” field will set where that column will start from the left position of the 

page. 

 

Note if the Left Position is set to 0, that column is NOT DISPLAYED! 

 

The “Field Width” will set how wide the column can go. 

The “Format” is exists will be the decimal point format. 

 

The columns that can be enabled are as follows … 

 

Column Name Description 

Plant Name The plant name where the Docket was batched 

Plant Number the plant number where the Docket was batched. 

Delivery Date The delivery date the Docket was batched 

Docket The docket number 

Product Code the product code of the Recipe or the Miscellaneous item 

Order Number the purchase order number from the customer 

Description this is the Description of the Recipe or Miscellaneous item, it could 

also be the order number, delivery address, docket number 

depending on the settings in the generation section 

Quantity this is the quantity of the recipe usually in CuM or quantity of the 

miscellaneous items 

Units –– this is units of the item in question (I.e. CuM or kg ect) 

 

Rate this is the cost rate per unit 

Rate with GST this is the cost rate per unit but including GST 

Price this is the cost (Quantity * Rate) 

TAX this is the GST component of the Price 
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5.4 Summary 

 

The summary section is displayed at the end of the Invoice but before the footer. 

 

To enable this section check “Settings->Invoice Layout ->Summary->Enable 

Summary Section”. 

 

 
 

To set the Section background color double click with the left mouse on the Section 

Color and color dialog box will appear, then select a color. 

 

To set the height of the section type the height in “Section Height”. Typical values are 

around 600 to 1000. 

 

55..44..11  CCoosstt  TToottaallss    

 

To show the Cost sub totals type a Top position that is greater than zero. To show the 

titles type a Titles Text Top Position that is also greater than zero. 

You can change the font and the text Color as well. 

 

55..44..22  TToottaall  PPaayyaabbllee  

 

To show the amount payables (it includes GST) then check “Show Amount Payable”. 

Set the Font, Text Color and Left and Top positions. 

Show the preferred static text that will appear to the left of the amount payable. 
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5.5 Footer 

 

The Footer section appears on every page. 

 

To set the height of this section set “Settings->Invoice layout->Footer->Section 

Height”. Typical values are around 2000 to 4000. 

 

You can set the background color with “Settings->Invoice layout->Footer->Section 

Color”. 

 

 
 

You can draw a line at the top of the Footer section by checking “Top Line”. You can 

then set the thickness of the line and the color. 

  

55..55..11  AAdddd  aa  LLooggoo  ttoo  tthhee  FFooootteerr  

 

You can add a picture to the footer section. 

 

In the Picture file section check “Show Picture”. Use the ellipsis button to locate the 

picture file. Type in the Left and Top positions of the picture from the top of the 

Footer section. Check “Show as Watermark” if you wish the picture to be a 

watermark. 

55..55..22  AAdddd  FFooootteerr  TTeexxtt  

 

You can add some text, by typing the text in the footer Text box. 
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You can then set the left and top position of the text as well as the font and the color 

of the text. 

 

You can add up to another 6 different texts with its own font and format in the 

following sections 

 

Settings->Invoice Layout->Footer->Footer Texts. 

Settings->Invoice Layout->Footer->Footer Texts2. 

 

55..55..33  AAdddd  FFooootteerr  PPaaggee  NNuummbbeerr  

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 2->Footer 

Page Number. 

 

Check “Show Page Number” to display the footer page number.  Set the position with 

The Left and Top positions entries and set the Font and Text Forecolor. 

 

55..55..44  AAdddd  FFooootteerr  TToottaall  AAmmoouunntt  PPaayyaabbllee  IInnccll..  GGSSTT  

 

This will display the Total Amount Payable including the GST in the footer Section. 

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 2->Footer 

Total Amount Payable Incl. GST. 

 

 
 

Check “Show Total Payable” to display the Total Payable Amount. This will be 

displayed at the Left and Top position show at the bottom. 

 

If you type the text this will be displayed at the Left and Top positions above the text. 

 

Set the Font and Text color.  

 

If you check “Show only on last page” this will only display on the last page. 
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55..55..55  AAdddd  IInnvvooiicceerr  NNuummbbeerr  ttoo  FFooootteerr  

 

This will display the Invoice Number in the footer Section. 

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 2->Footer 

Invoice Number. 

 

 
 

Check “Show Invoice Number” to display the Invoice number in the Footer section. 

Set the Left and Top position of the Invoice Number with Left and Top Position fields 

at the bottom. 

 

Type the static text in the text field box. This will positioned by the Text Left Position 

and Top Position fields above where the text is written. 

 

Set the Font and Text Color of the texts. 

 

 

55..55..66  DDiissppllaayy  CCuussttoommeerr  CCooddee  iinn  FFooootteerr  

 

This will display the Customer Code in the footer Section. 

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 3->Footer 

Customer Code. 

 

 
Check “Show Customer Code” to display the Customer Code in the Footer section. 

Set the Left and Top position of the Customer Code with the Left and Top Position 

fields at the bottom. 

 

Set the Font and Text Color of the texts. 
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55..55..77  DDiissppllaayy  FFooootteerr  TToottaall  AAmmoouunntt  PPaayyaabbllee  EExxccll  GGSSTT  

 

This will display the Total Amount Payable NOT including the GST in the footer 

Section. 

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 3->Footer 

Total Amount Payable Excl. GST. 

 

  
 

Check “Show Total Payable” to display the Total Payable Amount. This will be 

displayed at the Left and Top position show at the bottom. 

 

If you type the text this will be displayed at the Left and Top positions above the text. 

 

Set the Font and Text color.  

 

If you check “Show only on last page” this will only display on the last page. 

 

 



Invoicer Software Operator's Manual                  22/06/2018 

 

Page - 39 

 

55..55..88  DDiissppllaayy  FFooootteerr  TToottaall  AAmmoouunntt  PPaayyaabbllee  GGSSTT  OOnnllyy  

 

This will display the Total Amount Payable GST only component in the footer 

Section. 

 

You can set this in Settings->Invoice Layout->Footer->Footer Options 3->Footer 

Total Amount Payable (GST Only). 

 

  
 

Check “Show Total Payable” to display the Total Payable Amount. This will be 

displayed at the Left and Top position show at the bottom. 

 

If you type the text this will be displayed at the Left and Top positions above the text. 

 

Set the Font and Text color.  

 

If you check “Show only on last page” this will only display on the last page. 
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55..55..99  DDiissppllaayy  SSuummmmaarryy  CCoossttss  iinn  FFooootteerr  

 

This will display the Total Price (excl GST), the GST amount and the Total Price 

including the GST in the footer section. 

 

You can set this in “Settings->Invoice Layout->Footer->Footer Options 3->Footer 

Summary”. 

 

 

 
 

To enable the summary values check “Show Summary Values”. The three price 

values will be displayed on one line matching their appropriate columns in the Detail 

section. These values you can set the top position, the font and text color. 

 

You can also set the text explanations if you like by typing in the text and again 

positioning this in the line where it says text Component. You can set a different font 

and color for this. 

 

Check “Show on Last Page” if you wish to show this only on the last page. 
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6 Setting Up your Printing and Emailing 

 

6.1 Settings in Customer Table 

 

Some settings that will apply to printing and email are found in the Customer Table. 

 

In the Invoice Tab of the Customer Form here are the fields and their explanations. 

 

66..11..11  IInnvvooiicceerr  AAddddrreessss  LLiinnee  11  ttoo  44  

This is the postal address for the Invoice. This will find its way from AxiBatch to 

Invoicer. 

 

66..11..22  EEmmaaiill  AAddddrreessss  ffoorr  IInnvvooiicciinngg  

 

There are 2 fields for Email Addresses here. This will find its way from AxiBatch to 

Invoicer. 

 

66..11..33  SSttaattuuss  

 

Selectable. This is only for AxiBatch use and can prevent the operator from batch for 

that client if status is set to “Stop Credit” 

 

 

66..11..44  AAccccoouunntt  CCooddee  

 

This is the code for the Customer in the accounting package. When exporting Invoices 

from Invoicer, and you are sending the customer name or code, this will replace it so 

your accounting software will understand what customer it is. 

 

66..11..55  IInnvvooiiccee  MMooddee  

 

This directs Invoicer how to send the Invoicer to the customer. If blank, Invoicer will 

use other criteria to send it. 

 

Select the appropriate option. 

 

 

 



Invoicer Software Operator's Manual                  22/06/2018 

 

Page - 42 

6.2 Printing 

 

To enable printing in Invoicer, check “Settings->Invoices->Enable Printing”. 

 

 
Select the number of copies per Invoice. 

 

Select the printer you wish to use for Invoicing. If blank it will most likely print to the 

default printer. 

 

Check “Use Customer Invoice Mode First” if you want printing to be governed by the 

Customer setting. 

 

Check “Do not Print if Emailed” if you do not want anything printed if it has been 

emailed, regardless of Customer Invoice Mode. 

 

66..22..11  RReeppllaaccee  tthhee  RRaattee  wwiitthh  ““MMiinnii””  iiff  tthhee  ttrruucckk  ssiizzee  iiss  aa  MMiinnii  aanndd  pprriinnttiinngg  

aann  IInnvvooiiccee  

 

If you need to do this you can check this in “Settings->Invoices->Printing->Replace 

the Rate with ‘Mini’ if the Truck Size is a Mini. 
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6.3 Emailing 

 

To enable emailing check “Enable Email Facility” in “Settings->Invoices->Enable 

Email Facility”. 

 

To set up the Email account. Most of the email account fields need to be filled. 

This is found in “Settings->Invoices->Email”. 

 

 Outgoing Mail Server (SMTP) This is the name of your Internet Providers 

Outgoing Mail Server. 

 Port, this is the Port number that is used by the outgoing mail service.  

 Enable SSL, check this if your mail service uses SSL or TSL channel 

encryption 

 Account Name, this is your email Account Name 

 Logon User Name, this is your Account’s User Name 

 Logon Password, this is the password to your user account 

 From Address, the receiver will see this email address in their email software 

 From Name, the receiver will see this in the From field in their email 

 Master Email Address, all emailed invoices will be copied to this address 

 CC to, add other addresses invoices will be copied to 

 BC to, add other blind addresses invoices will be copied to 

 Set Importance to High, checking this will set the importance exclamation 

mark 

 Auto Add signature Image, this will add your signature as an image file to 

your invoice body. The image path and filename is added in text box below 

this. Use the ellipsis button to locate the file. 
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More settings are found in “Settings->Invoices->Email->Email2”. 

 

 
 

 Subject, this is the subject text that will appear in all subject fields for the 

emailed invoices 

 Body Message, the text in here is the standard text that will appear in the body 

of an email 

 Enable Email Input Box, checking this will enable you to change the Subject 

and Body when you manually email an invoice via a popup box. 

 Copy Default Subject, the popup that allows you to change the subject and 

body will copy the default subject 

 Copy Default Body, the popup that allows you to change the subject and body 

will copy the default body text 
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7 Setup Your Export 

 

These are your settings that will setup how exporting invoices to your accounting 

software will work. You can access these settings in “Settings->Export” 

 

 
 

 Export Type, here you select the accounting package you will be exporting 

to. Options are MYOB, XERO and others. 

 Use Header Fields, select the format of the Header fields if they are used. 

 Use Detail Fields, select the format of the Detail fields. These are always used 

and the format should always be the same as the format of the Header fields 

 Path where exported files are stored, this is directory path where the export 

fields created will be stored 

 Add Plant Code before Alias Description Code – Separator, use this option 

to add the Plant Code before the description with a separator if required 

 Add Delivery Date to start of Detail Description on Export, use this option 

to add the Delivery Date before the Invoice Description  

 Add Docket Number Field to end of Detail Description on Export, use this 

option to add the Docket Number after the Invoice Description  

 Add Docket Number Field to before Detail Description on Export, use this 

option to add the Docket Number before the Invoice Description  

 Add Delivery Address to end of Detail Description, use this option to add 

the Delivery Address after the Invoice Description  

 Convert a COD Customer Name to, use this to replace COD with something 

you type here  
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 Export Descriptions with Zero Quantities, check this to export things like 

delivery address that have zero quantities 

 Set Rate to Blank, check this set the Rate to a Blank if the Quantity is zero 

 Set Qty too Blank, check this to set the Qty field to a Blank if the Quantity is 

zero 

 Search Account Code/Name using Recipe Code only, check this to search 

account code using the Recipe Code. This is recommended as Recipe names 

and Descriptions are always being changed. 

 Search and Replace with Customer Account Coder, check this to replace 

the Customer Code or Name with the Customer Account Code from the 

Customer Table 

 Search Account Code using Plant Name, check this to narrow your search 

for account code by using the plant name. 

 

 

7.1 Setting up the Export Fields 

 

Press the “Setup Fields” button to access the export Fields. 

 

There is a list for Header fields and a list for Detail field. Not all accounting 

software’s will use the Header fields. 

 

The three lists on the left are Database Fields, these are from (starting from the top) 

the Account Table, the Main Invoice Table and the last table has items from the 

Invoice Details table. 

 

The top arrows in each left list box will move the selected field to the top right Header 

Field list. 

The bottom arrows in each left list box will move the selected field to the bottom right 

Details Fields. 

 

The Headers and Details List boxes on the right have 3 buttons. One to move the 

selected item up and one to move the selected item down, and the DEL button to 

remove the selected item 

 

These fields define how the export file will be created for the accounting software to 

be able to import. 
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7.2 Setting up for Xero 

 

77..22..11  PPrreeccoonnddiittiioonnss  

 

Make sure that all Recipes and Misc Items have descriptions. These are what used 

when generating invoices. 

 

Make use that all these are in the accounts table and a suitable account code is set up 

to match the item in Xero. 

 

In the accounts table setup, a row that has “Default” in the Recipe Code and Name. 

The account could be blank. This is used for things that are just text like order 

numbers and delivery addresses. 

 

In accounts setup the Account Number to match the Accounts Names in Xero. (The 

Account Names in Xero will have a number associated with that Name) 

 

77..22..22  EExxppoorrtt  LLiisstt  

 

No need to setup the Header List. 

 

Set the Details list as follows … 

 
INVOICE_CUSTOMER_NAMEINVOICE_CUSTOMER_NAMEINVOICE_CUSTOMER_NAMEINVOICE_CUSTOMER_NAME    
INVOICE_EMAIL_ADDRESSINVOICE_EMAIL_ADDRESSINVOICE_EMAIL_ADDRESSINVOICE_EMAIL_ADDRESS    
INVOICE_CUSTOMER_ADDRESS1INVOICE_CUSTOMER_ADDRESS1INVOICE_CUSTOMER_ADDRESS1INVOICE_CUSTOMER_ADDRESS1    
INVOICE_CUSTOMER_ADDRESS2INVOICE_CUSTOMER_ADDRESS2INVOICE_CUSTOMER_ADDRESS2INVOICE_CUSTOMER_ADDRESS2    
INVOICE_CUSTOMER_ADDRESS3INVOICE_CUSTOMER_ADDRESS3INVOICE_CUSTOMER_ADDRESS3INVOICE_CUSTOMER_ADDRESS3    
INVOICE_CUSTOMER_ADDRESS4INVOICE_CUSTOMER_ADDRESS4INVOICE_CUSTOMER_ADDRESS4INVOICE_CUSTOMER_ADDRESS4    
BlankBlankBlankBlank    
BlankBlankBlankBlank    
BlankBlankBlankBlank    
BlankBlankBlankBlank    
INVOICE_NUMBERINVOICE_NUMBERINVOICE_NUMBERINVOICE_NUMBER    
DETAIL_DELADDRESSDETAIL_DELADDRESSDETAIL_DELADDRESSDETAIL_DELADDRESS    
INVOICE_DEL_DATEINVOICE_DEL_DATEINVOICE_DEL_DATEINVOICE_DEL_DATE    
INVOICE_DUE_DATEINVOICE_DUE_DATEINVOICE_DUE_DATEINVOICE_DUE_DATE    
ACCOUNT_CODEACCOUNT_CODEACCOUNT_CODEACCOUNT_CODE    
DETAIL_DESCRIPTIONDETAIL_DESCRIPTIONDETAIL_DESCRIPTIONDETAIL_DESCRIPTION    
DETAIL_DETAIL_DETAIL_DETAIL_QUANTITYQUANTITYQUANTITYQUANTITY    
DETAIL_RATEDETAIL_RATEDETAIL_RATEDETAIL_RATE    
BlankBlankBlankBlank    
XeroAccountCodeXeroAccountCodeXeroAccountCodeXeroAccountCode    or ACCOUNT_NUMBERor ACCOUNT_NUMBERor ACCOUNT_NUMBERor ACCOUNT_NUMBER    
XeroTaxTypeXeroTaxTypeXeroTaxTypeXeroTaxType    
XeroTrackingName1XeroTrackingName1XeroTrackingName1XeroTrackingName1    
DETAIL_PLANT_CODEDETAIL_PLANT_CODEDETAIL_PLANT_CODEDETAIL_PLANT_CODE    (goes into tracking option 1)(goes into tracking option 1)(goes into tracking option 1)(goes into tracking option 1)    
BlankBlankBlankBlank    
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BlankBlankBlankBlank    
BlankBlankBlankBlank    
DETAIL_PLANT_CODEDETAIL_PLANT_CODEDETAIL_PLANT_CODEDETAIL_PLANT_CODE    
 

Note: The Blank’s MUST be included or otherwise Xero will not encode the file 

correctly! 

 

 

77..22..33  EExxppoorrtt  SSeettttiinnggss  ffoorr  XXeerroo  

 

Check “Settings->Export->Export Descriptions with Zero Quantities”. 

Check “Settings->Export->Set Rate to Blank”. 

Check “Settings->Export->Set Qty to Blank”. 

Check “Settings->Export->Add Docket Number Field to end of Detail Description on 

Export”. 

 

In Xero Options section … 

 

 
 

 

Set “Tracking Name 1” to example “Division”, this is the name of the first (or only) 

tracking category as it appears on the sales invoice in Xero. 

 

Set “Tracking Option 1” to the name of one of the options that belong to the first 

tracking category. 

 

If you use DETAIL_PLANT_CODE in your export list there is no need to use the 

Tracking Name and Option. Your Plant Code becomes the tracking option. 
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Set “Tax Type” to “GST On Income”. 

 

Set “Xero Account Code” to the code number that is used for all the concrete sale 

items. This will work if use “XeroAccountCode” in your export list. If your account 

number varies, use “ACCOUNT_NUMBER” in your export list instead of 

“XeroAccountCode”. 

 

 

Notes: 

 

If the Customer Name or Customer Code exported does not match with what is in 

Xero, Xero will assume it is a new Contact! 
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7.3 Setting up for MYOB 

 

Note that when using MYOB to import the export file created by Invoicer, you need 

to map each time you do this. 

 

77..33..11  MMYYOOBB  EExxppoorrtt  LLiisstt  

 

Your Export list should be as follows … 

 

The Header List is not required. 

 

The recommended Detail List is as follows … 

 
INVOICE_CUSTOMER_NAME 

INVOICE_NUMBER 

INVOICE_DEL_ADDRESS1 

INVOICE_DEL_ADDRESS2 

DETAIL_DELIVERY_DATE 

DETAIL_QUANTITY 

ACCOUNT_CODE 

DETAIL_DESCRIPTION 

ACCOUNT_NAME 

DETAIL_TOTAL 

DETAIL_RATE 

DETAIL_GST 

INVOICE_DATE 

 

77..33..22  IImmppoorrttiinngg  iinnttoo  MMYYOOBB  aanndd  mmaappppiinngg  

 

When using MYOB to import the export file created by Invoicer, you need to map 

each time you do this. 

 

The following table shows the Invoicer Header you map to MYOB.  

 

Invoicer // MYOB 

------------------------------- 

Customer Name // Co.Last Name: 

Invoice Number // Invoice #: 

Del address 1 // Addr 1 - Line 1: 

Del address 2 // Addr 2 - Line 2: 

Delivery Date // Date: 

Quantity // Quantity: 

Account Code // Item Number: 

Description // Description: 

Total Price Incl GSt // Total: 

Rate // Price: 

GST // GST Amount: 
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To import in MYOB you use the following … 

File->Import Data->Sales->Sales Item 

 

 

7.4 Setting up for SYBIZ 
 

77..44..11  SSyybbiizz  HHeeaaddeerr  EExxppoorrtt  LLiisstt  

 

INVOICE_CUSTOMER_CODE 

Blank 

INVOICE_DEL_DATE 

INVOICE_NUMBER 

ACCOUNT_NUMBER 

INVOICE_TOTAL_PRICE 

Zero Numeric 

Zero Numeric 

Sybiz Tax Code 2 

INVOICE_TOTAL_GST 

Zero Numeric 

  

 

 

77..44..22  SSyybbiizz  DDeettaaiillss  eexxppoorrtt  LLiisstt  

 
DETAIL_PLANT_NO 

Sybiz Credit Sale 

DETAIL_INVOICE_NUMBER 

ACCOUNT_NUMBER 

DETAIL_QUANTITY 

DETAIL_PRICE 

Zero Numeric 

Zero Numeric 

Sybiz Tax Code 2 

DETAIL_GST 

Zero Numeric 
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77..44..33  SSeettttiinnggss  ffoorr  SSyybbiizz  

 

This is accessed in “Settings->Export->Sybiz Options”. 

 

 
 

Set the directory of where the Clean (empty) Autoload.dbf file is stored. 

 

Set the directory of where the generated AutoLoad.dbf will reside when exported. It 

will always replace the older one. 

 

Check “Automatically check that the AutoLoad.dbf file has been processed before 

generating” to check that it has been imported into Sybiz. 

 

Check “Just append records if there are unprocessed records in the AutoLoad file” if 

you wish to add export records regardless. 

 

 

77..44..44  SSyybbiizz  TToooollss  

 

 

Use Tools->Sybiz to perform the following actions for testing. 

 

Use “Read AutoLoad database” to view the Export AutoLoad File. 

 

Use “Clear AutoLoad Database” to empty the file. 
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7.5 Setting up for Quickbooks 

 

In AxiBatch make sure you have Descriptions in all Recipes and Miscellaneous items. 

 

In the AxiBatch Customer Table, put the Customer Name in the Invoice Address Line 

1 so that when exported to QuickBooks the invoice box will have the Customer Name 

and address. 

 

In the Accounts Table make sure you set up Account Code field to match the 

QuickBooks Invoice Item. 

 

In the Accounts Table make sure you set up Account Name field to match the 

QuickBooks Account Name. Make sure use the full column to include separate sub 

items. I.e. Sales:Concrete Batching 

 

77..55..11  QQuuiicckkBBooookkss  EExxppoorrtt  HHeeaaddeerrss  LLiisstt  

 

Set the Export Headers to the following 

 

INVOICE_NUMBER 
INVOICE_CUSTOMER_NAME or INVOICE_CUSTOMER_CODE 
INVOICE_DEL_DATE 
INVOICE_TOTAL_AMOUNT_PAYABLE 
INVOICE_CUSTOMER_ADDRESS1 
INVOICE_CUSTOMER_ADDRESS2 
INVOICE_CUSTOMER_ADDRESS3 
INVOICE_CUSTOMER_ADDRESS4 
INVOICE_DEL_ADDRESS1 
INVOICE_DEL_ADDRESS2 
INVOICE_DEL_ADDRESS3 
INVOICE_DEL_ADDRESS4 
INVOICE_DUE_DATE 
QBOOKS_DATE    
 

Note that Customer Name or Customer Code must match the Customer Code in 

QuickBooks. 

 

77..55..22  QQuuiicckkBBooookkss  EExxppoorrtt  DDeettaaiillss  LLiisstt  

 

Set the Details List to the following 

 

ACCOUNT_NAME (matches Account in QB) 
ACCOUNT_CODE (matches Item in QB) 
DETAIL_DESCRIPTION 
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DETAIL_QUANTITY 
DETAIL_RATE 
DETAIL_PRICE 
DETAIL_GST 
 

 

77..55..33  EExxppoorrtt  SSeettttiinnggss  ffoorr  QQuuiicckkBBooookkss  

 

In Export Settings 

 

Set Export Descriptions with Zero Quantities 

Set Rate to Blank 

Set Add Docket Number Field to end of Detail Description 
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7.6 Setting up for Sage Pastel 

 

77..66..11  SSaaggee  PPaasstteell  HHeeaaddeerr  EExxppoorrtt  LLiisstt  

 
INVOICE_NUMBER 

Space 

Space 

INVOICE_CUSTOMER_CODE 

Period 

INVOICE_DEL_DATE 

INVOICE_ORDER_NO 

Y 

Discount 

Space 

Space 

Space 

INVOICE_DEL_ADDRESS1 

INVOICE_DEL_ADDRESS2 

INVOICE_DEL_ADDRESS3 

INVOICE_DEL_ADDRESS4 

Blank 

Blank 

Settlement 

INVOICE_DEL_DATE 

Space 

Space 

Space 

Exchange Rate 

Space 

Space 

N 

Y 

 

 

77..66..22  SSaaggee  PPaasstteell  DDeettaaiillss  EExxppoorrtt  LLiisstt  

 

Cost Price 

DETAIL_QUANTITY 

DETAIL_RATE 

RATE with GST 

DETAIL_UNITS 

Tax Type 

Discount Type 

Discount Percentage 

ACCOUNT_CODE 

DETAIL_DESCRIPTION 

Line Type 

Cost Code 

Store 
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8 Setup your Accounts Table 

 

To access the Accounts Table, select “Master Database->Accounts”. 

 

The accounts table needs to be populated, in order to successfully export invoices to 

your accounting software. 

 

 

8.1 Import Recipe Data 

 

This probable only needs to be done once per plant. 

 

Press the “Scan” button. 

 

The following screen will appear. 

 

 
 

Select “Scan from Recipe Table”, select the Plant. 

 

If you wish to copy the Recipe Codes to Account Codes, Recipe Names to Account 

Names, Recipe Descriptions to Account Descriptions, then select the appropriate 

selection and enable “Copy into the selected fields …”. 
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You can automatically enable each entry, otherwise each new entry will not be 

enabled. If this is the case it may make it easier to go through each record that is not 

enabled, and enabling it manually as you revise each record 

 

Press the START SCAN button to proceed. 

 

Once finished, you will need to review each new record and make sure you have the 

correct Account Number, Account Code or Name depending on which accounting 

package you are using. 

 

After this is done any new Recipes or Miscellaneous records that are added after will 

automatically allow you add the new account code or name as you go while you are 

generating. To enable this handy function check “Settings->Invoices->Generation-

>Perform Check on Account Code”. 

 

8.2 Editing the Account Records 

 

Once your data is in make sure you edit the Account Number or Code or Name and or 

Description that you require for your accounting package. 

 

If the account is valid for all plants, select “ALL” for the Plant Name or otherwise 

select the actual Plant Name. It will already have the Plant Name by default when you 

did the scan. There is the option to set all records Plant Name to “ALL” by pressing 

the “Add Plant Name to ALL Accounts” this will copy the current Plant Name or 

“ALL” to the Plant Name field in all accounts. 

 

Remember to press the Save  button you have finished editing. Otherwise press 

the rollback button  and then press Yes to the prompt to revert back to what you 

have before you started editing. 

 

Note: 

Add a “Default” record by setting the Recipe Code and Name to Default. In this 

way if you have a delivery address in the Invoice Description that does not match a 

Recipe, the export will send a different account code. 

 

Don’t forget to Enable your records otherwise they will not have been detected in 

the Export. 
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9 Start Invoicing 

 

The following is the process followed for Invoicing. 

 

Login to your Invoice Database you want to use if you have multiple Invoice 

Databases, otherwise select “None” to select the default Invoice database. 

 

The following process is assuming you have set everything up! 

 

9.1 Import Data – Step 1 

Select “Invoice Actions->Step 1 – Import Data” or press the icon to start 

importing dockets from AxiBatch. 

 

The following screen appears. 

 

 
 

Select the Plant you wish to receive the dockets from. Note if you have Multiple 

Invoice Databases, only the plants that are attached to this Invoice Database (you can 

see this in Plant Table) you have connected to at Login will appear in the list. 

 

Press the “Connect” button to connect to the Plant. “N/A” will change to display that 

you have connected to the Plant. If you do not get a connection then it may be the 

plant have turned off the Computer or the network is down. 

 

Check “Overwrite” if you wish to overwrite all the dockets that are visible in Step 2. 

This is usually the default case. The only time you would select merge is if you are 

wishing to generate invoices that include dockets from 2 or more plants. The Merge 

would be selected on the 2nd import, after you have connected to the second plant. 

Select the Date Range you wish to import the Dockets from. 
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You can optionally import individual dockets or docket for a particular customer. 

You would use “Select a Docket” if a batch was generated later after you had already 

invoiced. You would use “Select a Customer” if you were generating an Invoice for 

that Customer differently to all other Invoices.  

 

Press the “Start Import” button to import the dockets with the criteria you have 

selected. 

 

9.2 Review and Edit Data – Step 2 

Select “Invoice Actions->Step 2 – Edit Data” or press the icon. 

 

A list of all the dockets imported will appear. If you do not want to Invoice some of 

these dockets for the reason you will do it later because you will pick a different 

generation method, then you will need to remove them from the list. Removing them 

here does not delete them from the Plant’s Database. 

 

To remove the docket, select it on the Grid. Right click with the mouse and select 

“Remove Docket”. 

 

It is advisable to remove dockets that have already been invoiced. You can do this by 

pressing “SCAN for Dockets already Invoiced”.  When this Scan screen opens you 

can select to remove these Dockets for Invoicing by checking “Delete Docket in Load 

Table found already Invoiced”. Check “with Prompt” if you want Invoicer to ask you 

to remove the docket. Press “Scan” to start the removal. 

 

You can use “Show Filters” to display certain dockets. This filter is only for the 

display, it does not remove dockets for generation. 

 

You can use “Show Associated Dockets” to view all the dockets that are related to the 

same order as the docket you have selected. Again, this is only for display and does 

not remove all other dockets. 

 

You can edit dockets from here, and Invoicer will also update the dockets at the plant 

at the same time. However, this is advisable to do this using Console, and before you 

import into Invoicer. Right click with the mouse and select “Change Docket Details” 

to fix the customer code or pricing. Right click with the mouse and select “Show and 

Edit Details” to fix minor items such as Order Number / Comment etc. Right click 

with the mouse and select “Change Misc Items” to fix Miscellaneous Items in the 

Docket. Refer to the AxiBatch manual for more details on using Console to fix 

dockets. 

 

Note it is not advisable to fix dockets if the Plant computer or network is down! 

 

There are settings that are related to this step. 
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To force Calculation of Costs in Step 2 when changing some details, make sure you 

check “Settings->Invoices->Step2or4Editing->Force Calculation of Costs on 

changing Load Details”.  

 

To enable the removal of dockets check “Settings->Invoices->Step2or4Editing-

>Enable Removal of Docket in Invoice Database”. 

 

To enable the editing of dockets check “Settings->Invoices->Step2or4Editing->Allow 

Editing of Step 2 Load Data”. 
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9.3 Generate Invoices (Step 3) from the Dockets availble in 
Step 2 

Select “Invoice Actions->Step 3 – Generate Invoices” or press the icon. 

 

The following will be displayed. 

 

 

 
 

 

Check “Override and make due Date” to set the due date to the date set in the Date 

box to the right of it. This date can be altered. If not checked the Due Date will be set 

to the current date with the offset days that is stipulated in settings. (“Settings-

>Invoices->Generation->Due Date Offset”). 

 

Check “Override and make Invoice Date” to set Invoice Date to the date set in the 

Date box to the right of it. This date can be altered. If not checked the Invoice Date 

will be set to the current date. 

 

Press the “GENERATE INVOICES” button to start generating Invoices. 

Invoices will be generated based on the method selected in “Settings->Invoices-

>Generation->Generation Type”. Refer to this setting in the Generation Mode section 

of this manual. 

 

As Invoices are generating, text will appear in the text box to the right. It can also 

issue warning messages like zero concrete costs etc. 

 

At the end of the generation, it will prompt you if you wish to save the generated 

invoices to the Invoice database. If you say yes, then this will update the start Invoice 

Numbers for Step 4 (Editing Invoices), 5 (Printing and Emailing) and 6 (Exporting). 

During generation you may get a popup window telling you that an account number 

or code or name don’t exist for a Recipe Code that may not be in the Accounts table. 

You simply add the codes on the spot. 
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The above example is stating that there is no account code or name for 25 MPA 

Paving. Simply add the Account Code and Name as they appear in your accounting 

software, select the Plant and make sure it is Enabled and press “Add to Account 

Table”. The generation will continue. You can skip if you don’t know the code, but 

you will have to remember to add it manually to the accounts table before you next 

export. Use the “=>” keys to copy the Recipe Code to the Account Code if you need 

to.  

 

 

Use the “SAVE” button that appears below the text box to save the results of the text 

box to the default directory as per “Settings->Invoices->Generation->Default Path for 

Generation Results”. This does not save the Invoices! 
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9.4 Review and Edit Invoices (Step 4) 

 

To access the Invoices, select “Invoice Actions->Step 4 – Edit Invoices” or press 

 icon. 

 

When you do this, the Invoices that will be shown are the last lot that were generated. 

This can be changed by using “Show Filters” to display the filter screen to view any 

Invoices you wish. 

 

With the filter you can change the Invoice Number range as well as view Invoices 

with different date ranges using either or combination of Invoice date, Delivery Date 

and Due Dates. You can even search for an Invoice with a particular docket. Note 

closing the Step 4 screen and reopening it again will display the last lot of generated 

invoices. 

 

There are different ways you can edit parts of the Invoice. 

 

99..44..11  EEddiittiinngg  ppaarrttss  ooff  tthhee  MMaaiinn  IInnvvooiiccee  ddiirreeccttllyy  iinn  tthhee  IInnvvooiicceess  SSccrreeeenn..  

 

You can edit the following cells on the main Invoice Screen, Order No, Total Qty, 

Email, Email 2, Delivery Address 1,23&4, Customer Invoice Address 1,2,3 &4. Use 

the Save icon on the screen to save those edited changes. The Invoice date can also be 

edited if you check “Settings->Invoices->Step2or4Editing->Allow direct editing of 

the Invoice Date Field”. 

 

99..44..22  EEddiittiinngg  tthhee  DDeettaaiillss  ooff  tthhee  IInnvvooiiccee  

 

You can edit individual invoice details by selecting the invoice and with a right click 

of the mouse select “Show Invoice Details” or simply double click with the left 

mouse. 

 

The invoice will show all the individual lines. Any line can be edited. You can also 

insert a line or a blank line before or after a selected record. Any line cane be also 

removed. Some cells in the grid can be edited directly, however you need to check 

“Settings->Invoices->Step2or4Editing->Allow direct editing of the Detail Field”. 

These field that you can edit directly in the cell are “Order Number”, “Description”, 

“Qty”, “Rate” and “Delivery Address” fields. If you change the Qty or Rate the cost 

will be automatically updated for that line after you press the Enter key after typing 

the value. Pressing the Save icon will update the total costs. 
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To edit the line in another environment that will allow you to be able to change the 

recipe, right click with the mouse and select “Edit line”. The “Add/Insert Detail into 

Invoice” form will appear. You can change the product code, delivery date, docket as 

an example. Press the “Update Calculation” button to update the calculation. Select if 

Qty is counted towards the total CuM of concrete. Select the correct type. Press the 

“Update” button to update the line. This is also mainly used when you are inserting a 

new line. 

 

To insert a new line, right click with mouse and select Insert Line->Before or After to 

where you are currently selected. The same “Add/Insert Detail into Invoice” form will 

appear. 

 

To delete a line, select it and right click with the mouse and select “Delete Line”. 

 

On the same Invoice Editor form you can edit the Invoice Address, Top Right. You 

can also edit the email address, change the Customer Code or Name and the Due 

Date. 

 

Anything you edit on the Invoice Editor Form you will need to press the Save  

icon. 

 

When you close the Invoice Editor Form the main Invoice screen will update. 

 

99..44..33  PPaaiidd  SSttaattuuss  

 

The Invoice Status field will display if the Invoice is Paid. This is set manually, by 

right clicking with the mouse and selecting “Set Invoice Status->To Paid”.  

 

This field can appear on the Invoice, see “Settings->Invoices->Invoice Layout-

>Header->Header Special Codes->Special codes 4->Paid Field”, also refer to this 

section in the manual. 

 

99..44..44  CChhaannggee  IInnvvooiiccee  PPrriinntt//EEmmaaiill  MMooddee  

 

To change how the Invoice is sent you can change this by right clicking with the 

mouse and selecting “Set Invoice Mode To” and then select any of the available 

printing/emailing options.  

 

99..44..55  RReeppoorrttss  

 

You can print an Invoice Summary report on the Invoices showing on the grid. This is 

useful for checking the imports into your accounting package. Select “Invoice 

Summary: from the Select a Report box, then press the “Print” button.  
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You can preview an Invoice by right click with the mouse and selecting “Preview 

Invoice”. You can print the Invoice if you wish from the preview screen. 

 

You can print an Invoice by right click with the mouse and selecting “Print Invoice 

(No Preview)”. 

 

You can email an Invoice by right click with the mouse and selecting “Email 

Invoice”. This will only be available if emailing is enabled in settings. 
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9.5 Batch Print and Email Invoices (Step 5) 

 

To access the batch printing of Invoices, select “Invoice Actions->Step 5 – Batch 

Print / Email Invoices” or press  icon. 

 

When you do this, the following screen will appear. 

 

 
 

The “from Invoice” number entry is usually set when you last batch printed invoices, 

kit will be the next Invoice number from what was last printed. 

 

The “to Invoice” number entry will be the last Invoice number that was last generated. 

 

This range can be edited. If you close the screen and reopen it the original number 

range will appear not the ones you edited. 
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Select “Run as Test (PDF Only)” if you want to test your Invoices. This will not email 

your invoices and will only create PDF versions of the invoices and will be saved to 

the directory you set in “Settings->Invoices->PDF TEST Path for Invoices under 

Review”. This will also not alter the From Invoice entry field. 

 

Set the Delay between each Invoice print/email in seconds. If you have a slow printer 

or internet email connection you may want to increase this time. 

 

Press the START button to start the batch print and email process. 

 

Press the PAUSE button to pause the process and START again to restart. 

 

At the end of the Print/Email job, the “From Invoice: field will automatically change 

to the next Invoice number that will be generated.  
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9.6 Batch Export Invoices to your Accounting Software (Step 
6) 

 

To access the batch printing of Invoices, select “Invoice Actions->Step 5 – Batch 

Print / Email Invoices” or press  icon. 

 

When you do this, the following screen will appear. 

 

 
 

 

The “from Invoice” Number field is auto set when it last exported and will be the 

Invoice Number that was last exported plus one. 

 

The “to Invoice” Number field is auto set when it last generated and will be the last 

Invoice Number that was generated. 

 

The Invoice Number fields can be change. If the screen is closed and reopened, the 

original Invoice Number range will reappear, not the ones edited by you. 

 

Press the START button the commence the export. A prompt will ask you where to 

save it and what file name. The file created here will be the file you import with your 

accounting package. 
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9.7 Undo the Last Generated Invoices 

 

If you have generated and started editing the Invoices but realised this is not what you 

wanted, you can undo all last Invoices that you have generated. 

 

Select “Tools->Delete Invoice Range”. 

 

The following screen will appear. 

 

 
 

The “from Invoice” and “to Invoice” fields will usually be the last Invoices that were 

generated. However, these fields can be edited. Be very careful! 

 

Press the “Start Deletion” button to proceed. A prompt will ask if you wish to 

continue. Reply Yes to continue, no to cancel. 

 

At the end it will show you which Invoices were deleted, and what Invoice Number 

the Invoice Generator will be set to, and what the next Invoice Number will be. 

 

You are now ready to import and generate again. 

 

 


